我们在使用Android Studio的时候新建项目没什么问题的,但是当我们下载一份Github上的项目导入进去的时候却没法正常使用,其原因主要是gradle配置问题。而由于gradle这个玩意儿版本更新太快,android Studio每个版本也不一样。比如2.3版本使用gradle的版本是3.3,而2.4版本使用的是3.4.1.那么这个时候会出现什么问题呢?当你使用Android Studio 2.4版本导入一个2.3版本的项目的话就会出现需要修改gradle的版本。有时候Android Studio比较智能会自己修改的,但是有时候就没那么幸运了,比如下面这个图:

Error:(1, 0) Gradle version 2.2 is required. Current version is 3.4.1.  
Please fix the project's Gradle settings.  
"fixGradleVersionInWrapper">Fix Gradle wrapper and re-import project
"openGradleSettings">Gradle settings

那针对这个问题该怎么解决呢?这个时候你需要修改gradle文件夹下的wrapper文件夹下的gradle-wrapper.properties文件中distributionUrl值,这个值根据你当前Android Studio版本来的。还需要修改项目根目录下的build.gradle文件中的classpath的值,这个值也是随Android Studio版本走,比如2.4 preview 3版本使用的是'com.android.tools.build:gradle:2.4.0-alpha3'。贴下详细的内如:

gradle-wrapper.properties

#Sat Apr 01 16:21:14 CST 2017
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-3.4.1-all.zip

build.gradle

buildscript {
    repositories {
        jcenter()
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.4.0-alpha3'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

好了,修改完同步一下就可以了。如果还是报题目说的错误,那你就要检查下你AS的版本了,记住版本要对应上。