sh-4.1# /etc/init.d/mysqld status
 ERROR! MySQL is not running, but lock file (/var/lock/subsys/mysql) exists
sh-4.1# /etc/init.d/mysqld start
Starting MySQL. ERROR! The server quit without updating PID file (/data1/mysql/mysql.pid).
sh-4.1# rm mysql 
sh-4.1# /etc/init.d/mysqld status
 ERROR! MySQL is not running
sh-4.1# /etc/init.d/mysqld start
Starting MySQL. ERROR! The server quit without updating PID file (/data1/mysql/mysql.pid).

看了一下mysql的日志有如下错误:

170104  9:44:06 [Note] /apps/mysql-5.5.38/bin/mysqld: Shutdown complete

170104 09:44:06 mysqld_safe mysqld from pid file /data1/mysql/mysql.pid ended
170104 09:46:12 mysqld_safe Starting mysqld daemon with databases from /data1/mysql/
170104  9:46:12 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
170104  9:46:12 [Note] Plugin 'FEDERATED' is disabled.
170104  9:46:12 InnoDB: The InnoDB memory heap is disabled
170104  9:46:12 InnoDB: Mutexes and rw_locks use GCC atomic builtins
170104  9:46:12 InnoDB: Compressed tables use zlib 1.2.3
170104  9:46:12 InnoDB: Using Linux native AIO
170104  9:46:12 InnoDB: Initializing buffer pool, size = 2.0G
InnoDB: mmap(2197815296 bytes) failed; errno 12
170104  9:46:12 InnoDB: Completed initialization of buffer pool
170104  9:46:12 InnoDB: Fatal error: cannot allocate memory for the buffer pool
170104  9:46:12 [ERROR] Plugin 'InnoDB' init function returned error.
170104  9:46:12 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
170104  9:46:12 [ERROR] Unknown/unsupported storage engine: InnoDB
170104  9:46:12 [ERROR] Aborting

170104  9:46:12 [Note] /apps/mysql-5.5.38/bin/mysqld: Shutdown complete

170104 09:46:12 mysqld_safe mysqld from pid file /data1/mysql/mysql.pid ended

从err日志,可以看出,我分配的Initializing buffer pool, size = 2.0G,使得机器无法初始化。导致mysql启动不起来。

这个值=>my.cnf的innodb_buffer_pool_size

sh-4.1# grep "innodb-buffer-pool-size" /etc/my.cnf 
innodb-buffer-pool-size        = 1G
#innodb-buffer-pool-size        = 2G

问题解决启动成功!!!!